Fred Dispense
Issue
Users may notice that suddenly all scripts are being rejected by PBS with an Error obtaining access token.
Cause
This error happens when the store's B2B device used for PBS online claiming in PRODA becomes locked, often due to a power outage at the pharmacy.
Resolution
To resolve the issue, you need to log into your PRODA account, generate a new activation code for the B2B device, and import it into Fred Dispense.
- Log into the Proda account: Generally, only the pharmacy owner or someone with a high permission level can access the option to manage a B2B device in Proda.
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Manage B2B device in Proda: For more details, visit this link.
- Navigate to the locked B2B device and generate a new device activation code.
- Copy this code to import it into Fred Dispense in the next step.
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Import the new B2B device into Fred Dispense:
This step needs to be completed on only one of the dispense PCs.
- In Fred Dispense, from the Setup menu, select PBS-Online, then PBS Online Web Services (PRODA).
The PRODA PBS Online Configuration popup displays. - Click Edit.
- Enter the new Device Activation Code and click Activate.
A message will display confirming your device has been activated successfully.
- In Fred Dispense, from the Setup menu, select PBS-Online, then PBS Online Web Services (PRODA).
All rejected scripts should automatically re-transmit within the next 20 to 30 minutes. If they do not re-transmit after this time, contact Fred support for further assistance.
Related Links
Proda 300 Error getting access token due to locked B2B device (Fred Dispense Plus)