Fred Dispense
Issue
Unable to continue installing the latest monthly Fred Dispense update. The following error displays:
System Upgrade can't run because Fred Dispense or Fred Connect is currently running on a computer!
Cause
Fred Dispense data files are currently open or being accessed. All data files must be closed to allow the monthly update to run.
Any applications that can access Fred Dispense data files also need to be closed and exited. This includes Fred Dispense, Fred Connect, Fred Pak, and any other third-party applications that can access data from Fred Dispense.
Resolution
Step 1: Make sure that Fred Dispense is closed on the server and all terminals
- Check the server and each dispense terminal to make sure Fred Dispense is not running on the Windows taskbar. If it is running, right-click on the icon and select Close window.
- Check Task Manager on each terminal to make sure that winifred.exe is not running:
- Press [Ctrl]+[Shift]+[Esc].
- Select the Processes tab.
- View the list of processes.
- If winifred.exe is running, select it, then select End task.
Step 2: Make sure that Fred Connect is not running
Follow the steps below on the Fred Connect terminal:
There is always only one terminal with Fred Connect and this is identified by blue icon with white arrow.
- Check the Windows system tray (normally found on the bottom right-hand corner of the screen, next to the clock) to see if the Fred Connect icon exists.
You may also need to check the hidden icons that can be accessed through the Up arrow.
- If the Fred Connect icon exists, right click the icon and select Stop.
Step 3: Make sure that any third-party apps that access Fred Dispense data are closed
Make sure that any other third-party applications that are able to open and access Fred Dispense data files are also closed and exited using the same checking methods above. For example, this may include dose administration packing applications.
If you're unable to locate the running application that is preventing you from installing the monthly update, then do the following:
- Shut down all other terminals (except for the terminal/server where you're attempting to install the update).
- Run the monthly update again.